Debian Jessi Update unter openVZ

Unter einem openVZ System mit einem Kernel älter als 2.6.32-37-pve, kann ein „normales Update dazu führen, dass diese VM nicht mehr korrekt startet. Mit folgender Befehlsfolge kann dies vermieden werden:

System aktualisieren:

apt-get update && apt-get upgrade -y
dpkg --audit

Sourcen editieren:

nano /etc/apt/sources.list
deb http://ftp.de.debian.org/debian/ jessie main contrib non-free
deb-src http://ftp.de.debian.org/debian/ jessie main contrib non-free

deb http://security.debian.org/ jessie/updates main contrib non-free
deb-src http://security.debian.org/ jessie/updates main contrib non-free

deb http://ftp.de.debian.org/debian/ jessie-updates main contrib non-free
deb-src http://ftp.de.debian.org/debian/ jessie-updates main contrib non-free

Pakete aktualisieren

apt-get update && apt-get upgrade -y
apt-get dist-upgrade

sysvinit installieren

apt-get install sysvinit-core
reboot

systemd deinstallieren

apt-get remove systemd libsystemd0
Enter: Yes, do as I say!
apt-get autoremove
reboot

Nicht fertig konfigurierte Pakete konfigurieren

dpkg --configure --pending

Noch ein Check

dpkg --audit
reboot

Tags:, , , ,